Dependency on System.Web.Mvc 3.0.0.0

May 27, 2013 at 8:26 AM
Similar to:
https://mvcrouteunittester.codeplex.com/discussions/285799

I have setup unit tests that run on my computer that have MVC 2,3,4 installed. People who have only 2 and 4 installed get the error

System.IO.FileNotFoundException : Could not load file or assembly 'System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

When I uninstalled 3.0.0.0 from my computer (having only 2 and 4 installed), I started getting the same error as well. So, there is a hard reference to v 3.0.0.0 in the project and cannot be run on 4.0.0.0.
May 27, 2013 at 9:00 AM
I have found a fork version that works with MVC 4

http://mvcrouteunittester.codeplex.com/SourceControl/network/forks/manzo/MVC4

but it would be nice to be able to get this functionality it in the main version via nuGet.
Jan 7, 2014 at 1:18 PM
Bump. Why is it still not a Nuget package? Who maintains it?
Jan 8, 2014 at 8:31 AM
Update: I found the project MVC Route Tester, which does all this project does and more. This project is obsolete IMO.